Vulnerabilities / TranslatePress / WPSEC-2026-2456

TranslatePress <= 3.3.8 - Unauthenticated Stored Cross-Site Scripting via trp-ajax.php Endpoint

Medium 6.1 CWE-79Fixed in 3.3.9
ID
WPSEC-2026-2456
Plugin
TranslatePress – Translate Multilingual sites with AI Translation (translatepress-multilingual)
Affected
all versions before 3.3.9
Remediation
Update to 3.3.9 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-04
Attack surface
TranslatePress on WPSec AttackSurface
Fix released
Published

Description

The TranslatePress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the standalone trp-ajax.php endpoint in all versions up to, and including, 3.3.8. The endpoint returns stored translation dictionary strings with json_encode() but sends no JSON content type and does not escape HTML characters, so the response can be rendered as HTML when opened as a top-level page. This makes it possible for unauthenticated attackers to execute arbitrary web scripts in the site's origin when a victim is tricked into loading a crafted request to the endpoint, for example through an auto-submitting form, provided a malicious string such as an SVG event handler is present in the translation dictionary.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0