Spectra Legacy – Gutenberg Blocks <= 2.20.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Counter Block 'data-counter' Attribute
- ID
- WPSEC-2026-2457
- Plugin
- Spectra Legacy – Gutenberg Blocks (ultimate-addons-for-gutenberg)
- Affected
- from 2.5.0 before 2.20.6
- Remediation
- Update to 2.20.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin High · Affected versions High among sites WPSec scans, 2026-11-04
- Attack surface
- Spectra Legacy – Gutenberg Blocks on WPSec AttackSurface
- Fix released
- Published
Description
The Spectra Legacy – Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Counter block's 'data-counter' HTML attribute in all versions up to, and including, 2.20.5, due to the front-end counter script parsing options from that attribute in the saved post markup, letting them override the server-generated options, and passing the unsanitized thousand separator value to the CountUp library, which writes the formatted number with innerHTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2457/
- https://plugins.svn.wordpress.org/ultimate-addons-for-gutenberg/tags/2.20.6/
- https://wordpress.org/plugins/ultimate-addons-for-gutenberg/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS