Vulnerabilities / LifterLMS / WPSEC-2026-2480
LifterLMS <= 10.3.2 - Unauthenticated Sensitive Information Exposure via REST API Sections and Access Plans Endpoints
Medium 5.3
CWE-200Fixed in 11.0.0
- ID
- WPSEC-2026-2480
- Plugin
- LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes (lifterlms)
- Affected
- all versions before 11.0.0
- Remediation
- Update to 11.0.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- LifterLMS on WPSec AttackSurface
- Fix released
- Published
Description
The LifterLMS plugin for WordPress is vulnerable to Sensitive Information Exposure via the REST API sections and access plans endpoints in all versions up to, and including, 10.3.2 due to missing read permission checks on the parent course or membership and missing scoping of the collection queries. This makes it possible for unauthenticated attackers to list and read sections of unpublished, private or otherwise unreadable courses, as well as hidden access plans and access plans of courses or memberships they cannot read.
References
- https://wpsec.com/vuln/WPSEC-2026-2480/
- https://plugins.svn.wordpress.org/lifterlms/tags/11.0.0/
- https://wordpress.org/plugins/lifterlms/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS