Vulnerabilities / Simple Staff List / WPSEC-2026-2495
Simple Staff List <= 2.2.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'group' Shortcode Attribute
Medium 6.4
CWE-79Fixed in 2.2.6
- ID
- WPSEC-2026-2495
- Plugin
- Simple Staff List (simple-staff-list)
- Affected
- all versions before 2.2.6
- Remediation
- Update to 2.2.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- Simple Staff List on WPSec AttackSurface
- Fix released
- Published
Description
The Simple Staff List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'group' attribute of the simple-staff-list shortcode in all versions up to, and including, 2.2.5 due to insufficient output escaping when the attribute is placed into an HTML class attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2495/
- https://plugins.svn.wordpress.org/simple-staff-list/tags/2.2.6/
- https://wordpress.org/plugins/simple-staff-list/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS