Simple Staff List <= 2.2.5 - Authenticated (Editor+) Stored Cross-Site Scripting via Staff List Template
- ID
- WPSEC-2026-2496
- Plugin
- Simple Staff List (simple-staff-list)
- Affected
- all versions before 2.2.6
- Remediation
- Update to 2.2.6 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- Simple Staff List on WPSec AttackSurface
- Fix released
- Published
Description
The Simple Staff List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the staff list template settings in all versions up to, and including, 2.2.5 due to insufficient input sanitization of the template HTML for users lacking the unfiltered_html capability and missing output escaping of the saved template and CSS in the settings textareas. This makes it possible for authenticated attackers with access to the template settings (editor-level and above) to inject arbitrary web scripts that execute on the front end and in the admin area. This only affects multisite installations and installations where unfiltered_html has been disabled.
References
- https://wpsec.com/vuln/WPSEC-2026-2496/
- https://plugins.svn.wordpress.org/simple-staff-list/tags/2.2.6/
- https://wordpress.org/plugins/simple-staff-list/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS