PowerPress Podcasting plugin by Blubrry <= 11.18.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes and Media URL

Medium 4.9 CWE-79Fixed in 11.18.2
ID
WPSEC-2026-2499
Plugin
PowerPress Podcasting plugin by Blubrry (powerpress)
Affected
all versions before 11.18.2
Remediation
Update to 11.18.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
Attack surface
PowerPress Podcasting plugin by Blubrry on WPSec AttackSurface
Fix released
Published

Description

The PowerPress Podcasting plugin by Blubrry plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'powerpress' shortcode's 'url', 'width' and 'height' attributes and episode media URLs in all versions up to, and including, 11.18.0. This is due to these values being placed inside JavaScript strings in onclick handlers and inline autoplay scripts of the HTML5 audio and video players with only htmlspecialchars() escaping, which does not protect a JavaScript context. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The HTML5 audio/video players are not the default player, so the site has to be set up to use them for the media type.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0