Vulnerabilities / Collapse Magic / WPSEC-2026-2505
Collapse Magic <= 1.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
Medium 6.4
CWE-79Fixed in 1.6.1
- ID
- WPSEC-2026-2505
- Plugin
- Collapse Magic (collapse-magic)
- Affected
- all versions before 1.6.1
- Remediation
- Update to 1.6.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- Collapse Magic on WPSec AttackSurface
- Fix released
- Published
Description
The Collapse Magic plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the shortcode's title, swaptitle, icon and swapicon attributes in all versions up to, and including, 1.5.0. This is due to the plugin's front-end JavaScript reading these values from data attributes and inserting them into the page as HTML without sanitization when rendering the toggle button. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2505/
- https://plugins.svn.wordpress.org/collapse-magic/tags/1.6.1/
- https://wordpress.org/plugins/collapse-magic/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS