Vulnerabilities / ЮKassa для WooCommerce / WPSEC-2026-2510
ЮKassa для WooCommerce <= 2.17.3 - Unauthenticated Insecure Direct Object Reference to Payment Status Disclosure via 'order-id' Parameter
Medium 5.3
CWE-639Fixed in 2.17.4
- ID
- WPSEC-2026-2510
- Plugin
- ЮKassa для WooCommerce (yookassa)
- Affected
- all versions before 2.17.4
- Remediation
- Update to 2.17.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-639
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-04
- Attack surface
- ЮKassa для WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The ЮKassa для WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference via the 'order-id' parameter of the yookassa_check_payment AJAX action in all versions up to, and including, 2.17.3, due to the checkPaymentStatus() function looking up any order by its ID without verifying the order key, the order owner, or the user's capabilities. This makes it possible for unauthenticated attackers to retrieve the YooKassa payment status of other customers' orders and the order's payment link, which contains the order key.
References
- https://wpsec.com/vuln/WPSEC-2026-2510/
- https://plugins.svn.wordpress.org/yookassa/tags/2.17.4/
- https://wordpress.org/plugins/yookassa/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS