Vulnerabilities / WP Inventory Manager / WPSEC-2026-2522
WP Inventory Manager <= 2.5.9 - Reflected Cross-Site Scripting via 'message' Parameter in Reservation Form
Medium 6.1
CWE-79Fixed in 2.5.10
- ID
- WPSEC-2026-2522
- Plugin
- WP Inventory Manager (wp-inventory-manager)
- Affected
- all versions before 2.5.10
- Remediation
- Update to 2.5.10 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- WP Inventory Manager on WPSec AttackSurface
- Fix released
- Published
Description
The WP Inventory Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'message' query parameter of the item reservation form in all versions up to, and including, 2.5.9, due to insufficient input sanitization and output escaping. The value is read from the URL, URL-decoded and printed unescaped into the front-end reservation message. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-2522/
- https://plugins.svn.wordpress.org/wp-inventory-manager/tags/2.5.10/
- https://wordpress.org/plugins/wp-inventory-manager/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS