Számlázz.hu integráció WooCommerce-hez <= 6.3 - Unauthenticated Invoice Data Manipulation via Invoice Override Parameters
- ID
- WPSEC-2026-2527
- Plugin
- Integration for Szamlazz.hu and WooCommerce (integration-for-szamlazzhu-woocommerce)
- Affected
- all versions before 6.3.1
- Remediation
- Update to 6.3.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-345
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- Számlázz.hu integráció WooCommerce-hez on WPSec AttackSurface
- Fix released
- Published
Description
The Integration for Szamlazz.hu and WooCommerce plugin for WordPress is vulnerable to invoice data manipulation in all versions up to, and including, 6.3 due to the invoice generation routine reading override parameters such as 'paid', 'note', 'deadline', 'completed', 'doc_type', 'lang', 'account' and 'reason' directly from the request without verifying a nonce or the origin of the request. This makes it possible for unauthenticated customers, when invoices are generated automatically during their own requests (for example at checkout or on an automated status change), to alter the generated invoice, such as marking it as paid, injecting notes, changing the deadline or language, or switching the Számlázz.hu account used.
References
- https://wpsec.com/vuln/WPSEC-2026-2527/
- https://plugins.svn.wordpress.org/integration-for-szamlazzhu-woocommerce/tags/6.3.1/
- https://wordpress.org/plugins/integration-for-szamlazzhu-woocommerce/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS