Vulnerabilities / Co-Authors Plus / WPSEC-2026-2531

Co-Authors Plus <= 4.2.0 - Authenticated (Contributor+) Improper Authorization to Guest-Authored Post Editing via Username Collision

Medium 4.2 CWE-863Fixed in 4.2.1
ID
WPSEC-2026-2531
Plugin
Co-Authors Plus (co-authors-plus)
Affected
from 3.0 before 4.2.1
Remediation
Update to 4.2.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-863
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
Attack surface
Co-Authors Plus on WPSec AttackSurface
Fix released
Published

Description

The Co-Authors Plus plugin for WordPress is vulnerable to Improper Authorization via the co-author capability mapping in all versions up to, and including, 4.2.0, due to the is_coauthor_for_post() function treating a registered user as a co-author whenever their user_login matches the user_login of a guest author bylined on the post, even when that guest author is not linked to the user. This makes it possible for authenticated attackers, with Contributor-level access and above, whose username matches an unlinked guest author's login, to be treated as a co-author of that guest author's posts and to view and edit posts they could not otherwise access, such as drafts and pending posts.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0