Vulnerabilities / VK All in One Expansion Unit / WPSEC-2026-2543
VK All in One Expansion Unit <= 9.123.1 - Authenticated (Contributor+) Sensitive Information Exposure via CTA Block
Medium 4.3
CWE-200Fixed in 9.124.0
- ID
- WPSEC-2026-2543
- Plugin
- VK All in One Expansion Unit (vk-all-in-one-expansion-unit)
- Affected
- from 9.80.0.0 before 9.124.0
- Remediation
- Update to 9.124.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
- Attack surface
- VK All in One Expansion Unit on WPSec AttackSurface
- Fix released
- Published
Description
The VK All in One Expansion Unit plugin for WordPress is vulnerable to Sensitive Information Exposure via the Call To Action (CTA) block in all versions up to, and including, 9.123.1. This is due to the block's render callback loading the post given in the block's postId attribute with get_post() and only rejecting trashed posts, instead of restricting it to published CTA posts. This makes it possible for authenticated attackers with Contributor-level access and above to render and view the content of draft, private, password-protected or other non-public posts of any post type.
References
- https://wpsec.com/vuln/WPSEC-2026-2543/
- https://plugins.svn.wordpress.org/vk-all-in-one-expansion-unit/tags/9.124.0/
- https://wordpress.org/plugins/vk-all-in-one-expansion-unit/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS