Vulnerabilities / STAGGS / WPSEC-2026-2576

STAGGS <= 3.3.0 - Unauthenticated Remote Code Execution via Configurator Price Calculation

High 8.1 CWE-95Fixed in 3.4.0
ID
WPSEC-2026-2576
Plugin
STAGGS – Product Configurator Toolkit (staggs)
Affected
from 1.2.1 before 3.4.0
Remediation
Update to 3.4.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-95
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
Attack surface
STAGGS on WPSec AttackSurface
Fix released
Published

Description

The STAGGS plugin for WordPress is vulnerable to Remote Code Execution via the configurator price calculation in all versions up to, and including, 3.3.0, due to submitted configurator option values being concatenated into strings that are passed to PHP's eval() when unit-priced or formula-priced input fields are recalculated server-side, for example when a configured product is added to the cart. This makes it possible for unauthenticated attackers to execute arbitrary PHP code on the server, provided the site has a configurable product that uses a unit-priced or formula/measurement-priced input attribute.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0