Vulnerabilities / Theme Builder For Elementor / WPSEC-2026-2577
Theme Builder For Elementor <= 1.2.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets' 'text' Setting
Medium 6.4
CWE-79Fixed in 2.0.0
- ID
- WPSEC-2026-2577
- Plugin
- Theme Builder For Elementor (theme-builder-for-elementor)
- Affected
- all versions before 2.0.0
- Remediation
- Update to 2.0.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
- Attack surface
- Theme Builder For Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The Theme Builder For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'text' setting of the Read More Button, Post Author, Post Date, Post Categories, Post Tags and Post Comments Elementor widgets in all versions up to, and including, 1.2.5, due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above who can edit posts with Elementor, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2577/
- https://plugins.svn.wordpress.org/theme-builder-for-elementor/tags/2.0.0/
- https://wordpress.org/plugins/theme-builder-for-elementor/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS