Vulnerabilities / EmbedPress / WPSEC-2026-2585

EmbedPress <= 4.7.1 - Authenticated (Subscriber+) Server-Side Request Forgery via oEmbed Discovery

Medium 6.4 CWE-918Fixed in 4.7.2
ID
WPSEC-2026-2585
Plugin
EmbedPress (embedpress)
Affected
all versions before 4.7.2
Remediation
Update to 4.7.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-918
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-05
Attack surface
EmbedPress on WPSec AttackSurface
Fix released
Published

Description

The EmbedPress plugin for WordPress is vulnerable to Server-Side Request Forgery via oEmbed discovery in all versions up to, and including, 4.7.1. This is because the bundled Embera library fetches oEmbed endpoints with its own cURL/file_get_contents client, which skips WordPress URL validation and the plugin's internal-host blocking, and some providers (such as Didacte and SlateApp) build the endpoint host from part of the user-supplied URL. The 'embedpress_get_embed_url_info' AJAX action can be called by any logged-in user without a capability or nonce check, and the classic-editor code path that registers it can be loaded by adding a request parameter. Contributors can also reach the same fetch through the plugin's shortcode. This makes it possible for authenticated attackers, with subscriber-level access and above, to make web requests to arbitrary locations originating from the web application, which can be used to query and modify information from internal services.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0