Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent <= 1.2.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
- ID
- WPSEC-2026-2593
- Plugin
- Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent (tablesome)
- Affected
- all versions before 1.2.16
- Remediation
- Update to 1.2.16 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
- Attack surface
- Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent on WPSec AttackSurface
- Fix released
- Published
Description
The Tablesome Table – Contact Form DB – WPForms, CF7, Gravity, Forminator, Fluent plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the [tablesome] shortcode's 'table_id', 'post_id' and 'exclude_column_ids' attributes in all versions up to, and including, 1.2.15, due to insufficient input sanitization and output escaping when these values are printed into the table container's HTML attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2593/
- https://plugins.svn.wordpress.org/tablesome/tags/1.2.16/
- https://wordpress.org/plugins/tablesome/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS