Vulnerabilities / WP Data Access / WPSEC-2026-2606

WP Data Access <= 5.5.90 - Authenticated (Contributor+) Stored Cross-Site Scripting via Dynamic Hyperlink Column Values

Medium 4.9 CWE-79Fixed in 5.5.91
ID
WPSEC-2026-2606
Plugin
WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps (wp-data-access)
Affected
all versions before 5.5.91
Remediation
Update to 5.5.91 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
WP Data Access on WPSec AttackSurface
Fix released
Published

Description

The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via column values substituted into dynamic hyperlinks shown in data entry forms in all versions up to, and including, 5.5.90, due to insufficient output escaping. Row values replace the $$column$$ placeholders in the hyperlink template, and the result was echoed into the href attribute and the link markup without escaping. This makes it possible for authenticated attackers, with contributor-level access and above, who can store data in a table that has a dynamic hyperlink configured, to inject arbitrary web scripts that execute whenever a user opens the affected record in the form.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0