Vulnerabilities / WP Data Access / WPSEC-2026-2608

WP Data Access <= 5.5.90 - Authenticated (Subscriber+) SQL Injection via Environment Variable Substitution

Medium 5.3 CWE-89Fixed in 5.5.91
ID
WPSEC-2026-2608
Plugin
WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps (wp-data-access)
Affected
from 4.2.0 before 5.5.91
Remediation
Update to 5.5.91 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-89
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
WP Data Access on WPSec AttackSurface
Fix released
Published

Description

The WP Data Access plugin for WordPress is vulnerable to SQL Injection via the $$EMAIL$$ (and $$USER$$) environment variables in default WHERE clauses in all versions up to, and including, 5.5.90, due to the current user's email address and login being placed into the SQL query by plain string replacement, without escaping or preparation. This makes it possible for authenticated attackers, with subscriber-level access and above, whose account email address contains quote characters (which WordPress allows), to append additional SQL to existing queries and extract sensitive information from the database. Exploitation requires that a default WHERE clause using these environment variables has been configured.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0