Vulnerabilities / Leaky Paywall / WPSEC-2026-2618
Leaky Paywall <= 5.3.2 - Unauthenticated Payment Bypass via PayPal IPN for Another Merchant Account
Low 3.7
CWE-345Fixed in 5.3.3
- ID
- WPSEC-2026-2618
- Plugin
- Leaky Paywall (leaky-paywall)
- Affected
- all versions before 5.3.3
- Remediation
- Update to 5.3.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-345
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-05
- Attack surface
- Leaky Paywall on WPSec AttackSurface
- Fix released
- Published
Description
The Leaky Paywall plugin for WordPress is vulnerable to a payment bypass via the PayPal Standard IPN listener in all versions up to, and including, 5.3.2. This is due to the plugin not checking that a PayPal-verified IPN was for a payment to the site's configured PayPal account. This makes it possible for unauthenticated attackers to send a genuine IPN from a payment made to an account they control to the site's listener and obtain a paid subscription without paying the publisher.
References
- https://wpsec.com/vuln/WPSEC-2026-2618/
- https://plugins.svn.wordpress.org/leaky-paywall/tags/5.3.3/
- https://wordpress.org/plugins/leaky-paywall/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS