Vulnerabilities / Leaky Paywall / WPSEC-2026-2619

Leaky Paywall <= 5.3.2 - Unauthenticated Payment Bypass via Forged PayPal IPN

Medium 5.3 CWE-345Fixed in 5.3.3
ID
WPSEC-2026-2619
Plugin
Leaky Paywall (leaky-paywall)
Affected
from 5.0.8 before 5.3.3
Remediation
Update to 5.3.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-345
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
Attack surface
Leaky Paywall on WPSec AttackSurface
Fix released
Published

Description

The Leaky Paywall plugin for WordPress is vulnerable to a payment bypass via the PayPal Standard IPN listener in versions 5.0.8 up to, and including, 5.3.2. This is due to insufficient verification of data authenticity: when PayPal's verification endpoint did not answer VERIFIED, the plugin fell back to a self-validation that only checked request fields the sender controls (receiver email, payment status, invoice format, amount and the custom email). This makes it possible for unauthenticated attackers to forge PayPal payment notifications and create or activate paid subscriptions without paying.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0