Vulnerabilities / Optimole / WPSEC-2026-2623

Optimole <= 4.2.18 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Tag Attribute Values

Medium 6.4 CWE-79Fixed in 4.2.19
ID
WPSEC-2026-2623
Plugin
Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization (optimole-wp)
Affected
from 4.1.0 before 4.2.19
Remediation
Update to 4.2.19 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
Optimole on WPSec AttackSurface
Fix released
Published

Description

The Optimole plugin for WordPress is vulnerable to Stored Cross-Site Scripting via image tag attribute values in versions 4.1.0 up to, and including, 4.2.18, due to insufficient output escaping when the plugin adds missing width and height attributes to image tags. The plugin inserted the quoted width and height attributes with a plain string replacement on the text 'data-opt-id=', and that text can also appear inside an attribute value written by the post author, such as alt text. The inserted double quotes then close that value, so text the author placed after it is read as new attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0