Vulnerabilities / Mang Board / WPSEC-2026-2628

Mang Board <= 2.4.7 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Post Content

Medium 6.4 CWE-79Fixed in 2.4.8
ID
WPSEC-2026-2628
Plugin
Mang Board (mangboard)
Affected
all versions before 2.4.8
Remediation
Update to 2.4.8 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
Attack surface
Mang Board on WPSec AttackSurface
Fix released
Published

Description

The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site Scripting via board post content in all versions up to, and including, 2.4.7, due to content only being purified on save when the user-supplied 'data_type' parameter contains 'html', the 'data_type' value being updatable on modification without resubmitting content, and HTML content only being purified on output for posts written by guests (level 0). This makes it possible for authenticated attackers with board member access (Subscriber-level) and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0