Vulnerabilities / Events Manager – Calendar, Bookings, Tickets, Appointments and more! / WPSEC-2026-2641
Events Manager – Calendar, Bookings, Tickets, Appointments and more! <= 7.4.12 - Authenticated (Contributor+) Sensitive Information Exposure via 'event' and 'location' Shortcodes
Medium 4.3
CWE-200Fixed in 7.4.13
- ID
- WPSEC-2026-2641
- Plugin
- Events Manager – Calendar, Bookings, Tickets, Appointments and more! (events-manager)
- Affected
- all versions before 7.4.13
- Remediation
- Update to 7.4.13 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-06
- Attack surface
- Events Manager – Calendar, Bookings, Tickets, Appointments and more! on WPSec AttackSurface
- Fix released
- Published
Description
The Events Manager plugin for WordPress is vulnerable to Sensitive Information Exposure via the [event] and [location] shortcodes in all versions up to, and including, 7.4.12. This is due to the shortcodes rendering any event or location given by its 'event', 'location' or 'post_id' attribute without checking that the current visitor can read that post or has unlocked its password. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the details of other users' draft, pending or password-protected events and locations.
References
- https://wpsec.com/vuln/WPSEC-2026-2641/
- https://plugins.svn.wordpress.org/events-manager/tags/7.4.13/
- https://wordpress.org/plugins/events-manager/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS