Vulnerabilities / WPForms / WPSEC-2026-2656

WPForms <= 2.0.3.1 - Unauthenticated Email Field Validation Bypass to Notification Recipient Injection

Low 3.7 CWE-20Fixed in 2.0.4
ID
WPSEC-2026-2656
Plugin
WPForms – AI Form Builder for WordPress – Contact Forms, Payment Forms, Survey Form, Quiz & More (wpforms-lite)
Affected
all versions before 2.0.4
Remediation
Update to 2.0.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-20
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-06
Attack surface
WPForms on WPSec AttackSurface
Fix released
Published

Description

The WPForms plugin for WordPress is vulnerable to Email Validation Bypass via the Email field in all versions up to, and including, 2.0.3.1, due to the wpforms_is_email() function accepting any value containing a '{...}' smart tag pattern as a valid email address, including values submitted by visitors in the Email field. This makes it possible for unauthenticated attackers to submit an arbitrary comma-separated list of addresses (for example '[email protected],[email protected],{x}') as an email, which, on forms whose notification Send To or CC setting uses that Email field, causes the site to send the notification email to multiple attacker-chosen recipients.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0