FluentCommunity – Ultra-Fast High-Performance Social Network, Community, LMS & Online Courses <= 2.12.0 - Cross-Site Request Forgery to Invitation Acceptance
- ID
- WPSEC-2026-2661
- Plugin
- FluentCommunity – Ultra-Fast High-Performance Social Network, Community, LMS & Online Courses (fluent-community)
- Affected
- all versions before 2.13.0
- Remediation
- Update to 2.13.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-06
- Attack surface
- FluentCommunity – Ultra-Fast High-Performance Social Network, Community, LMS & Online Courses on WPSec AttackSurface
- Fix released
- Published
Description
The FluentCommunity plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.12.0 due to missing nonce validation on the 'auto_accept' invitation parameter of the auth page and on the logged-in path of the fcom_user_registration AJAX action, which still processed an 'invitation_token'. This makes it possible for unauthenticated attackers to force a logged-in user to accept a shareable link invitation, joining them to a space or community without consent, via a forged request granted they can trick the user into performing an action such as clicking a link.
References
- https://wpsec.com/vuln/WPSEC-2026-2661/
- https://plugins.svn.wordpress.org/fluent-community/tags/2.13.0/
- https://wordpress.org/plugins/fluent-community/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS