Vulnerabilities / woo-delivery / WPSEC-2026-2670

woo-delivery <= 1.3.90 - Authenticated (Subscriber+) Missing Authorization to Plugin Settings Update

Medium 4.3 CWE-862Fixed in 1.3.91
ID
WPSEC-2026-2670
Plugin
woo-delivery (woo-delivery)
Affected
all versions before 1.3.91
Remediation
Update to 1.3.91 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-06
Attack surface
woo-delivery on WPSec AttackSurface
Fix released
Published

Description

The woo-delivery plugin for WordPress is vulnerable to unauthorized modification of data via its AJAX settings-save actions (delivery options, delivery/pickup date and time, off days, localization and other settings) in all versions up to, and including, 1.3.90, due to a missing capability check on the handlers, which only verify a nonce that is also printed for any visitor of the checkout page. This makes it possible for authenticated attackers, with subscriber-level access and above, to overwrite the plugin's settings, for example to disable or reconfigure delivery/pickup date and time fields, change off days, and alter checkout labels, notices and custom CSS.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0