Falang multilanguage for WordPress <= 1.4.6 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure and Language Order Modification via AJAX Actions

High 7.1 CWE-862Fixed in 1.4.7
ID
WPSEC-2026-2724
Plugin
Falang multilanguage for WordPress (falang)
Affected
all versions before 1.4.7
Remediation
Update to 1.4.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-07
Attack surface
Falang multilanguage for WordPress on WPSec AttackSurface
Fix released
Published

Description

The Falang multilanguage for WordPress plugin for WordPress is vulnerable to unauthorized access and modification of data via several AJAX actions, including falang_option_translation, falang_post_translation and falang_language_ordering, in all versions up to, and including, 1.4.6, due to missing capability checks. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the value of arbitrary scalar site options (which may hold credentials or API keys), view the content of any post including private and draft posts, and change the order of the site's languages.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0