Vulnerabilities / GeoDirectory / WPSEC-2026-2725

GeoDirectory <= 2.8.202 - Unauthenticated Reflected Cross-Site Scripting via Location Replacement Variables

Medium 6.1 CWE-79Fixed in 2.8.203
ID
WPSEC-2026-2725
Plugin
GeoDirectory – WP Business Directory Plugin and Classified Listings Directory (geodirectory)
Affected
all versions before 2.8.203
Remediation
Update to 2.8.203 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-07
Attack surface
GeoDirectory on WPSec AttackSurface
Fix released
Published

Description

The GeoDirectory plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'country', 'region', 'city' and 'neighbourhood' query parameters in all versions up to, and including, 2.8.202, due to insufficient input sanitization and output escaping. The values are inserted into the location replacement variables (such as %%location_single%% and %%in_location_single%%) used in GeoDirectory page titles, meta titles and category descriptions. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a crafted link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0