Vulnerabilities / Envo's Templates & Widgets for Elementor and WooCommerce / WPSEC-2026-2726
Envo's Templates & Widgets for Elementor and WooCommerce <= 1.4.28 - Unauthenticated Sensitive Information Exposure via etww_ajax_search AJAX Action
Medium 5.3
CWE-200Fixed in 2.0.0
- ID
- WPSEC-2026-2726
- Plugin
- Envo’s Templates & Widgets for Elementor and WooCommerce (envo-elementor-for-woocommerce)
- Affected
- all versions before 2.0.0
- Remediation
- Update to 2.0.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-07
- Attack surface
- Envo's Templates & Widgets for Elementor and WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Envo’s Templates & Widgets for Elementor and WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure via the etww_ajax_search AJAX action in all versions up to, and including, 1.4.28. This is due to the handler accepting any post type from the request without limiting it to public, searchable post types. This makes it possible for unauthenticated attackers to list and search the titles and links of published entries of non-public post types, such as WooCommerce coupon codes.
References
- https://wpsec.com/vuln/WPSEC-2026-2726/
- https://plugins.svn.wordpress.org/envo-elementor-for-woocommerce/tags/2.0.0/
- https://wordpress.org/plugins/envo-elementor-for-woocommerce/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS