Advanced Post Block <= 2.5.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom SVG Icon Block Attributes
- ID
- WPSEC-2026-1687
- Plugin
- Advanced Post Block – Display Your Posts Exactly How You Want (advanced-post-block)
- Affected
- from 2.2.0 before 2.5.2
- Remediation
- Update to 2.5.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-27
- Attack surface
- Advanced Post Block on WPSec AttackSurface
- Fix released
- Published
Description
The Advanced Post Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the custom SVG icon block attributes (Read More icon and Accordion layout up/down indicator icons) in all versions up to, and including, 2.5.1, due to insufficient input sanitization and output escaping. The front-end script renders these attributes as raw HTML, and the block settings are embedded in the page in a way that lets saved HTML entities decode back into live markup. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1687/
- https://plugins.svn.wordpress.org/advanced-post-block/tags/2.5.2/
- https://wordpress.org/plugins/advanced-post-block/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS