CMB2 <= 2.13.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Grouped WYSIWYG Field
- ID
- WPSEC-2026-1792
- Plugin
- CMB2 (cmb2)
- Affected
- from 2.2.3 before 2.13.5
- Remediation
- Update to 2.13.5 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-27
- Attack surface
- CMB2 on WPSec AttackSurface
- Fix released
- Published
Also published later by Wordfence as CVE-2026-116761, on 2026-10-27.
Description
The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via WYSIWYG fields inside a repeatable group in versions 2.2.3 up to, and including, 2.13.4, due to insufficient output escaping of the saved field value. The value was printed into the placeholder textarea without esc_textarea and then inserted unescaped into the editor's JavaScript template, so entity-encoded markup that passes wp_kses_post is decoded and rendered as live HTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that execute when another user, such as an administrator, opens the edit screen of an affected post that uses a grouped WYSIWYG field.
References
- https://wpsec.com/vuln/WPSEC-2026-1792/
- https://plugins.svn.wordpress.org/cmb2/tags/2.13.5/
- https://wordpress.org/plugins/cmb2/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS