Mollie Payments for WooCommerce <= 8.1.11 - Unauthenticated Improper Input Validation to Restricted Product Purchase via PayPal Express Button
- ID
- WPSEC-2026-1833
- Plugin
- Mollie Payments for WooCommerce (mollie-payments-for-woocommerce)
- Affected
- all versions before 8.2.0
- Remediation
- Update to 8.2.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-20
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- Mollie Payments for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Mollie Payments for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation via the PayPal express button AJAX handlers in all versions up to, and including, 8.1.11, due to the product-page handler building a WooCommerce order from any product ID and quantity posted by the client, without checking that the product is published, purchasable, in stock, has enough stock, or is a product the button is offered for. This makes it possible for unauthenticated attackers to create and pay orders for private or draft products, out-of-stock items, or products the PayPal button is not shown for, bypassing the store's purchase restrictions. Exploitation requires the PayPal express button to be enabled.
References
- https://wpsec.com/vuln/WPSEC-2026-1833/
- https://plugins.svn.wordpress.org/mollie-payments-for-woocommerce/tags/8.2.0/
- https://wordpress.org/plugins/mollie-payments-for-woocommerce/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS