Vulnerabilities / Leaky Paywall / WPSEC-2026-1864
Leaky Paywall <= 5.3.0 - Unauthenticated Price Manipulation via 'plan_id' Parameter
Medium 5.3
CWE-472Fixed in 5.3.1
- ID
- WPSEC-2026-1864
- Plugin
- Leaky Paywall (leaky-paywall)
- Affected
- all versions before 5.3.1
- Remediation
- Update to 5.3.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-472
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-28
- Attack surface
- Leaky Paywall on WPSec AttackSurface
- Fix released
- Published
Description
The Leaky Paywall plugin for WordPress is vulnerable to price manipulation via the 'plan_id' parameter of the Stripe registration form in all versions up to, and including, 5.3.0, due to the Stripe price for a recurring subscription being taken from the hidden 'plan_id' field without checking that it matches the subscription level selected with 'level_id'. Registration completion then accepts any paid subscription on the customer. This makes it possible for unauthenticated attackers to get a more expensive level while being billed a cheaper Stripe price.
References
- https://wpsec.com/vuln/WPSEC-2026-1864/
- https://plugins.svn.wordpress.org/leaky-paywall/tags/5.3.1/
- https://wordpress.org/plugins/leaky-paywall/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS