jav's – WooCommerce and Trello integration WooTrello <= 3.3.1 - Cross-Site Request Forgery to Log and Integration Deletion
- ID
- WPSEC-2026-1889
- Plugin
- jav’s – WooCommerce and Trello integration WooTrello (wootrello)
- Affected
- all versions before 3.4.0
- Remediation
- Update to 3.4.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weakness
- CWE-352
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
- Attack surface
- jav's – WooCommerce and Trello integration WooTrello on WPSec AttackSurface
- Fix released
- Published
Description
The jav's – WooCommerce and Trello integration WooTrello plugin for WordPress is vulnerable to Cross-Site Request Forgery via the logStatus, deleteLog, removeInt and wootrello_toggle_products_in_card actions of the settings page in all versions up to, and including, 3.3.1, due to missing nonce validation on these state-changing GET actions in the Wootrello_settings_view() function. This makes it possible for unauthenticated attackers to delete all plugin logs or all configured integrations, or toggle logging and the product-list option, via a forged request, granted they can trick a site administrator into performing an action such as clicking a link.
References
- https://wpsec.com/vuln/WPSEC-2026-1889/
- https://plugins.svn.wordpress.org/wootrello/tags/3.4.0/
- https://wordpress.org/plugins/wootrello/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS