Post Grid Gutenberg Blocks <= 5.1.2 - Authenticated (Author+) Stored Cross-Site Scripting via Block CSS
- ID
- WPSEC-2026-1915
- Plugin
- Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX (ultimate-post)
- Affected
- all versions before 5.1.3
- Remediation
- Update to 5.1.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-10-29
- Attack surface
- Post Grid Gutenberg Blocks on WPSec AttackSurface
- Fix released
- Published
Description
The Post Grid Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the generated block CSS in all versions up to, and including, 5.1.2, due to the CSS sent to the /ultp/v1/save_block_css/ REST endpoint being stored unsanitized in the post's _ultp_css meta and CSS file, and later printed in an inline style element with wp_add_inline_style() without escaping, so a closing style tag in the CSS ends the style element. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1915/
- https://plugins.svn.wordpress.org/ultimate-post/tags/5.1.3/
- https://wordpress.org/plugins/ultimate-post/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS