Essential Addons for Elementor – Popular Elementor Templates & Widgets <= 6.8.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom JS Page Setting
- ID
- WPSEC-2026-1940
- Plugin
- Essential Addons for Elementor – Popular Elementor Templates & Widgets (essential-addons-for-elementor-lite)
- Affected
- all versions before 6.8.8
- Remediation
- Update to 6.8.8 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin High · Affected versions High among sites WPSec scans, 2026-10-29
- Attack surface
- Essential Addons for Elementor – Popular Elementor Templates & Widgets on WPSec AttackSurface
- Fix released
- Published
Description
The Essential Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS extension's page setting in all versions up to, and including, 6.8.7. This is due to the administrator-only restriction on Custom JS being applied only to Elementor's document save, while the eael_custom_js value in the _elementor_page_settings post meta, which can be written through the REST API by anyone who can edit the post, is copied unescaped into the page's front-end script on a later Elementor save. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary scripts that run whenever a user accesses the page, once the page is published and saved again in Elementor, for example by an administrator.
References
- https://wpsec.com/vuln/WPSEC-2026-1940/
- https://plugins.svn.wordpress.org/essential-addons-for-elementor-lite/tags/6.8.8/
- https://wordpress.org/plugins/essential-addons-for-elementor-lite/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS