Fast Velocity Minify <= 3.5.7 - Unauthenticated Stored Cross-Site Scripting via HTML Parser Placeholder Injection
- ID
- WPSEC-2026-1970
- Plugin
- Fast Velocity Minify (fast-velocity-minify)
- Affected
- all versions before 3.5.8
- Remediation
- Update to 3.5.8 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-29
- Attack surface
- Fast Velocity Minify on WPSec AttackSurface
- Fix released
- Published
Description
The Fast Velocity Minify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its bundled HTML parser in all versions up to, and including, 3.5.7. The cause is predictable internal noise placeholders, regex-based stashing of comments, script and style blocks that ignored attribute boundaries, and unescaped restoration of stashed content into attribute values. Every front-end page is re-parsed and re-serialized, so placeholder text or comment/script openers placed inside an attribute value can close the attribute early and inject new markup. This makes it possible for unauthenticated attackers who can submit HTML content such as comments with allowed attributes, as well as contributors through post content, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-1970/
- https://plugins.svn.wordpress.org/fast-velocity-minify/tags/3.5.8/
- https://wordpress.org/plugins/fast-velocity-minify/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS