MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions <= 5.0.20 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Store Description
- ID
- WPSEC-2026-1988
- Plugin
- MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions (dc-woocommerce-multi-vendor)
- Affected
- from 5.0.0 before 5.0.21
- Remediation
- Update to 5.0.21 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-10-29
- Attack surface
- MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions on WPSec AttackSurface
- Fix released
- Published
Description
The MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the store description submitted through store registration in versions 5.0.0 through 5.0.20, due to insufficient input sanitization and output escaping. The stores REST endpoint lets any logged-in user register a store and saved the description without sanitization, and the admin store details view renders it as raw HTML. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts that execute when an administrator views the store in the dashboard.
References
- https://wpsec.com/vuln/WPSEC-2026-1988/
- https://plugins.svn.wordpress.org/dc-woocommerce-multi-vendor/tags/5.0.21/
- https://wordpress.org/plugins/dc-woocommerce-multi-vendor/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS