Vulnerabilities / Themify Builder / WPSEC-2026-2156

Themify Builder <= 7.8.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom Font Variation Fields

Medium 6.4 CWE-79Fixed in 7.8.5
ID
WPSEC-2026-2156
Plugin
Themify Builder (themify-builder)
Affected
all versions before 7.8.5
Remediation
Update to 7.8.5 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-10-30
Attack surface
Themify Builder on WPSec AttackSurface
Fix released
Published

Also published later by Wordfence as CVE-2026-115869, on 2026-10-30.

Description

The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom Font 'variations' repeater fields (such as the font style and font file URLs) in all versions up to, and including, 7.8.4, due to insufficient input sanitization and output escaping. Repeater sub-field values were saved directly from the request, even for users without the unfiltered_html capability, and were later echoed unescaped into a style element in the Custom Fonts admin list and into generated @font-face rules. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page, such as an administrator viewing the Custom Fonts list.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0