Vulnerabilities / Wallet for WooCommerce / WPSEC-2026-2194
Wallet for WooCommerce <= 1.7.3 - Authenticated (Subscriber+) Payment Gateway Restriction Bypass via Wallet Top-Up Orders
Medium 4.3
CWE-284Fixed in 1.7.4
- ID
- WPSEC-2026-2194
- Plugin
- Wallet for WooCommerce (woo-wallet)
- Affected
- all versions before 1.7.4
- Remediation
- Update to 1.7.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-284
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Wallet for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Wallet for WooCommerce plugin for WordPress is vulnerable to a payment gateway restriction bypass in all versions up to, and including, 1.7.3 due to the "Allowed Payment Gateways" setting for wallet top-ups only being enforced on the cart, and not on the order-pay page, the Store API checkout route, or the REST API top-up endpoint. This makes it possible for authenticated attackers, with subscriber-level access and above, to pay for wallet top-up orders using payment gateways the store owner explicitly excluded for top-ups.
References
- https://wpsec.com/vuln/WPSEC-2026-2194/
- https://plugins.svn.wordpress.org/woo-wallet/tags/1.7.4/
- https://wordpress.org/plugins/woo-wallet/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS