AnyWhere Elementor <= 1.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Widget Settings
- ID
- WPSEC-2026-2198
- Plugin
- Dynific Addons for Elementor (formerly Anywhere Elementor) (anywhere-elementor)
- Affected
- all versions before 1.3.1
- Remediation
- Update to 1.3.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- AnyWhere Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The Dynific Addons for Elementor (formerly Anywhere Elementor) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several widget settings in all versions up to, and including, 1.3.0. Examples are the Post Meta labels and separators, the Post Navigation labels and separator, the Post Title 'title_tag' setting and the Post Author 'author_tag' and 'icon' settings. The cause is insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2198/
- https://plugins.svn.wordpress.org/anywhere-elementor/tags/1.3.1/
- https://wordpress.org/plugins/anywhere-elementor/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS