Vulnerabilities / FeedWordPress / WPSEC-2026-2257

FeedWordPress <= 2026.0517 - Unauthenticated Stored Cross-Site Scripting via Syndicated Feed Content

Medium 5.4 CWE-79Fixed in 2026.1016
ID
WPSEC-2026-2257
Plugin
FeedWordPress (feedwordpress)
Affected
all versions before 2026.1016
Remediation
Update to 2026.1016 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
FeedWordPress on WPSec AttackSurface
Fix released
Published

Also published later by Wordfence as CVE-2026-110530, on 2026-10-30.

Description

The FeedWordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via syndicated feed item content in all versions up to, and including, 2026.0517, due to the plugin deliberately removing WordPress's kses filters from content_save_pre before saving syndicated posts. As a result, raw feed HTML such as script tags, event handler attributes and javascript: URLs is stored without sanitization. This makes it possible for unauthenticated attackers who control, or can inject content into, a feed the site syndicates (for example a compromised feed or one that republishes user-submitted input) to inject arbitrary web scripts into posts that execute whenever a user, including an administrator, views the affected post.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0