Vulnerabilities / Cozy Blocks / WPSEC-2026-2268

Cozy Blocks <= 2.2.28 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block Attributes

Medium 6.4 CWE-79Fixed in 2.2.29
ID
WPSEC-2026-2268
Plugin
Cozy Blocks – Website Builder & Business Growth Toolkit | Popups, Lead Forms & Inbox (cozy-addons)
Affected
all versions before 2.2.29
Remediation
Update to 2.2.29 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
Cozy Blocks on WPSec AttackSurface
Fix released
Published

Description

The Cozy Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via block attributes, such as the block client ID used by numerous blocks (e.g., Accordion, Advanced Tab, Container, Counter, Form) and the Quick View block's icon alignment attribute, in all versions up to, and including, 2.2.28. This is due to insufficient input sanitization and output escaping. The client ID was inserted raw into inline JavaScript and script variable names, and the alignment value was placed unescaped into an HTML class attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0