Vulnerabilities / The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid / WPSEC-2026-2452
The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid <= 7.9.8 - Authenticated (Contributor+) Sensitive Information Exposure via Password-Protected Post Content
Medium 4.3
CWE-200Fixed in 7.9.9
- ID
- WPSEC-2026-2452
- Plugin
- The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid (the-post-grid)
- Affected
- from 5.0.0 before 7.9.9
- Remediation
- Update to 7.9.9 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
- Attack surface
- The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid on WPSec AttackSurface
- Fix released
- Published
Description
The The Post Grid plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'rttpg_block_css_get_posts' AJAX action (block CSS loader) in all versions up to, and including, 7.9.8, due to an insufficient 'read_post' capability check that does not account for post passwords and returns the raw post_content of any readable post. This makes it possible for authenticated attackers, with Contributor-level access and above, to retrieve the raw content of password-protected posts by supplying their post ID.
References
- https://wpsec.com/vuln/WPSEC-2026-2452/
- https://plugins.svn.wordpress.org/the-post-grid/tags/7.9.9/
- https://wordpress.org/plugins/the-post-grid/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS