Addon Elements for Elementor (formerly Elementor Addon Elements) <= 1.15 - Unauthenticated Sensitive Information Exposure via Post List and Timeline Widgets

Low 3.7 CWE-200Fixed in 1.15.1
ID
WPSEC-2026-2460
Plugin
Addon Elements for Elementor (formerly Elementor Addon Elements) (addon-elements-for-elementor-page-builder)
Affected
all versions before 1.15.1
Remediation
Update to 1.15.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
Attack surface
Addon Elements for Elementor (formerly Elementor Addon Elements) on WPSec AttackSurface
Fix released
Published

Description

The Addon Elements for Elementor (formerly Elementor Addon Elements) plugin for WordPress is vulnerable to Sensitive Information Exposure via the Post List and Timeline widgets in all versions up to, and including, 1.15 due to the widgets rendering the excerpt or content of posts without checking whether the post is password-protected. This makes it possible for unauthenticated attackers to read the excerpt or content of password-protected posts when a page containing one of these widgets lists such posts. Contributor-level users who can build Elementor content could also place these widgets to expose protected posts.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0