Dynamic Pricing With Discount Rules for WooCommerce <= 5.1.0 - Authenticated (Shop Manager+) Stored Cross-Site Scripting via Plugin Settings and Rule Label
- ID
- WPSEC-2026-2483
- Plugin
- Dynamic Pricing With Discount Rules for WooCommerce (aco-woo-dynamic-pricing)
- Affected
- all versions before 5.1.1
- Remediation
- Update to 5.1.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- Dynamic Pricing With Discount Rules for WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Dynamic Pricing With Discount Rules for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin settings (such as pricing table labels, custom saving messages, offer descriptions and style values) and the discount rule label in all versions up to, and including, 5.1.0, due to insufficient input sanitization and output escaping. Values saved through the plugin's REST API were printed on front-end cart and product pages without escaping, including inside style attributes. This makes it possible for authenticated attackers with Shop Manager-level access and above, who do not have the unfiltered_html capability by default, to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2483/
- https://plugins.svn.wordpress.org/aco-woo-dynamic-pricing/tags/5.1.1/
- https://wordpress.org/plugins/aco-woo-dynamic-pricing/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS