Advanced Form Integration <= 2.11.0 - Unauthenticated Missing Authorization to Administrator Role Change via WordPress Update User Role Action
- ID
- WPSEC-2026-2487
- Plugin
- Advanced Form Integration — Connect Forms to 300+ Apps (advanced-form-integration)
- Affected
- from 2.4.0 before 2.11.3
- Remediation
- Update to 2.11.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- Advanced Form Integration on WPSec AttackSurface
- Fix released
- Published
Description
The Advanced Form Integration plugin for WordPress is vulnerable to unauthorized modification of data via the WordPress "Update User Role" integration action in all versions up to, and including, 2.11.0. This is due to the action looking up the target account from a submitted user ID, username or email and changing its role without checking whether that account is an administrator or holds another privileged role. This makes it possible for unauthenticated attackers to demote administrators and other privileged users to the role configured in the integration, locking them out of the site's administration. Exploitation requires an active Update User Role integration whose user field is mapped to a submitted form value.
References
- https://wpsec.com/vuln/WPSEC-2026-2487/
- https://plugins.svn.wordpress.org/advanced-form-integration/tags/2.11.3/
- https://wordpress.org/plugins/advanced-form-integration/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS