Vulnerabilities / UsersWP / WPSEC-2026-2497

UsersWP <= 1.2.80 - Authenticated (Contributor+) Stored Cross-Site Scripting via uwp_user_badge Shortcode

Medium 6.4 CWE-79Fixed in 1.2.81
ID
WPSEC-2026-2497
Plugin
UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP (userswp)
Affected
from 1.2.2.4 before 1.2.81
Remediation
Update to 1.2.81 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
Attack surface
UsersWP on WPSec AttackSurface
Fix released
Published

Description

The UsersWP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the uwp_user_badge shortcode and block in all versions up to, and including, 1.2.80, due to insufficient input sanitization and output escaping on user-supplied attributes such as 'onclick', 'link', 'badge', 'hover_content' and 'hover_icon'. The 'onclick' value is written into an inline event handler, and the 'link' value is written into the badge's href without a protocol check. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0