Social Slider Feed <= 2.3.8 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'slidespeed' Feed Setting
- ID
- WPSEC-2026-2682
- Plugin
- Social Slider Feed – Social Media Feed & Gallery Widgets (instagram-slider-widget)
- Affected
- from 2.0.0 before 2.3.9
- Remediation
- Update to 2.3.9 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-06
- Attack surface
- Social Slider Feed on WPSec AttackSurface
- Fix released
- Published
Also published later by Wordfence as CVE-2026-121519, on 2026-11-06.
Description
The Social Slider Feed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'slidespeed' feed setting in all versions up to, and including, 2.3.8 due to insufficient input sanitization and the value being printed unquoted into inline JavaScript in the slider templates, where esc_js() offers no protection. Combined with the missing capability check on the feed editing pages, this makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts that execute whenever a user accesses a page displaying the affected feed.
References
- https://wpsec.com/vuln/WPSEC-2026-2682/
- https://plugins.svn.wordpress.org/instagram-slider-widget/tags/2.3.9/
- https://wordpress.org/plugins/instagram-slider-widget/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS