Vulnerabilities / Events Made Easy / WPSEC-2026-2741

Events Made Easy <= 3.3.5 - Unauthenticated Reflected Cross-Site Scripting via Bundled Fondy SDK Example Scripts

Medium 6.1 CWE-79Fixed in 3.3.6
ID
WPSEC-2026-2741
Plugin
Events Made Easy (events-made-easy)
Affected
all versions before 3.3.6
Remediation
Update to 3.3.6 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-08
Attack surface
Events Made Easy on WPSec AttackSurface
Fix released
Published

Description

The Events Made Easy plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the bundled Fondy payment SDK test and example scripts (such as payment_gateways/fondy/result.php and payment_gateways/fondy/examples/result.php) in all versions up to, and including, 3.3.5, due to insufficient output escaping. The scripts can be requested directly, turn on display_errors, and print the submitted request data back to the visitor without escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute in a victim's browser if they can trick the victim into submitting a crafted request, such as by visiting a malicious page with an auto-submitting form.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0